Star Wars: BattleCry

Development forum for Star Wars: BattleCry
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log in  

Share | 
 

 [SOLVED] CryEngine 3.4.3 Compatibility issue

Go down 
AuthorMessage
sceluk
void Work();


Posts : 364
Join date : 2012-11-07

PostSubject: [SOLVED] CryEngine 3.4.3 Compatibility issue   Sat Nov 24, 2012 8:29 pm

Its been out for a while actually. Just noticed today.
We gonna upgrade or what? They fixed a lot of stuff and added some new awesome lighting stuff.
Back to top Go down
View user profile
SharkYbg
Polygon Smith


Posts : 137
Join date : 2012-11-04
Age : 25
Location : Bulgaria

PostSubject: Re: [SOLVED] CryEngine 3.4.3 Compatibility issue   Sat Nov 24, 2012 9:33 pm

I have it for some time and I tested it a little.

One issue I found is that objects do not physicalize no matter what i try. All of my models i uploaded in dropbox do not physicalize in the 3.4.3 version while in 3.4.0 all is fine. You just go trough them. One thing is that the models don't have proxies but that shouldn't be the case.

Krymor's tested also the model of the snowspeeder i uploaded and his editor even crashed... It worked for him on the 3.4.0 version.

The lightning is fixed the 3.4.3 and i love the new features. But unless these problems are caused by new things that need tweaking so the collision and the physics work i think we shouldn't upgrade.
Back to top Go down
View user profile
sceluk
void Work();


Posts : 364
Join date : 2012-11-07

PostSubject: Re: [SOLVED] CryEngine 3.4.3 Compatibility issue   Sat Nov 24, 2012 10:55 pm

Hmm, that sucks. I guess you tried re exporting the models?
Back to top Go down
View user profile
SharkYbg
Polygon Smith


Posts : 137
Join date : 2012-11-04
Age : 25
Location : Bulgaria

PostSubject: Re: [SOLVED] CryEngine 3.4.3 Compatibility issue   Sat Nov 24, 2012 11:32 pm

Yes, i re exported the snowspeeder at least 5 times and no luck. I am sure it will be the same for the other models

Edit: I was too fast with the conclusion. Seems that the boxes and the really low poly models physicalize... What happens is that the higher poly models with more than 500 polys or so don't physicalize Shocked . Is it possible that there's an option to increase some sort of limit for physical models??

I will look into crydev if this issue has appeared somewhere.
Back to top Go down
View user profile
rocknroll237
Admin
avatar

Posts : 311
Join date : 2012-11-04
Age : 27
Location : Somerset

PostSubject: Re: [SOLVED] CryEngine 3.4.3 Compatibility issue   Sun Nov 25, 2012 12:49 am

I would definately tell the Crydev guys about this.

If you want to chat to any Crydev experts use this chat room: http://widget00.mibbit.com/?server=webirc.gamesurge.net:6007&channel=%23crymod

There is a thread here that explains more about the chat room: http://source.crydev.net/viewtopic.php?f=126&t=68623&start=0
Back to top Go down
View user profile http://www.moddb.com/games/star-wars-battlecry
Schlechtwetterfront

avatar

Posts : 446
Join date : 2012-11-05

PostSubject: Re: [SOLVED] CryEngine 3.4.3 Compatibility issue   Sun Nov 25, 2012 2:27 am

Maybe you need to create an actual physics mesh like the weapons have? The SCAR for example has a very lowpoly model with a special material applied around it which acts as the physics model ingame.
Models with a large polycount shouldn't be used as physics mesh because then collision calculation takes far too long.
Back to top Go down
View user profile https://sites.google.com/site/andescp/
sceluk
void Work();


Posts : 364
Join date : 2012-11-07

PostSubject: Re: [SOLVED] CryEngine 3.4.3 Compatibility issue   Sun Nov 25, 2012 4:56 am

Aha, so that's why. Schlechtwetterfront is correct. It's actually an optimization on the side of the engine. High poly models used as collision meshes are a waste of processing power, you need seperate low poly collission meshes.
I guess it easy enough to copy and decimate the original mesh. Don't forget to link the collission model to its high poly version (the high poly should be its parent). And apply the nodraw material to it.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: [SOLVED] CryEngine 3.4.3 Compatibility issue   

Back to top Go down
 
[SOLVED] CryEngine 3.4.3 Compatibility issue
Back to top 
Page 1 of 1
 Similar topics
-
» BSR A29 changer issue
» Binding issue
» 2 Dynaco MkII's same issue
» Hum issue in PAS Aikido
» Doomlord article in the new SFX

Permissions in this forum:You cannot reply to topics in this forum
Star Wars: BattleCry :: Development :: General development issues-
Jump to: